You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Fresh install of 1.88.1 fails on startup: '@opentelemetry/semantic-conventions' has no default export #1082
After a fresh global npm install of command-code@latest (1.88.1), cmd cannot start. Even cmd --version exits immediately with a module-loading SyntaxError, so the CLI is unusable until the dependency is manually downgraded.
Expected Behavior
A fresh npm i -g command-code@latest should produce a working CLI. cmd --version should print 1.88.1, and cmd should start normally without any manual patching.
Actual Behavior
Every invocation of cmd (including cmd --version) crashes before startup:
SyntaxError: The requested module '@opentelemetry/semantic-conventions' does not provide an export named 'default'
at #asyncInstantiate (node:internal/modules/esm/module_job:463:21)
at async ModuleJob.run (node:internal/modules/esm/module_job:561:5)
at async node:internal/modules/esm/loader:650:26
at async file:///.../.local/lib/node_modules/command-code/dist/index.mjs:2:1757
Steps to reproduce the issue
npm i -g command-code@latest
cmd --version
The CLI exits immediately with the SyntaxError above.
Command Code Version
1.88.1
Operating System
macOS
Terminal/IDE
Apple Terminal
Shell
zsh
Session file (optional)
N/A — the CLI crashes before a session can be created.
Fix prompt (optional)
In dist/cli.mjs, @opentelemetry/semantic-conventions is imported with a default import:
import ze from "@opentelemetry/semantic-conventions";
...
({ATTR_SERVICE_NAME: ZD, ATTR_SERVICE_VERSION: eN} = ze)
The dependency range in package.json is ^1.30.0, which now resolves to 1.44.0.
That version exposes its ESM entry (dist/index.mjs) via the default export
condition, and the ESM entry has no default export, so module loading fails.
Fix by importing the two named exports directly:
import { ATTR_SERVICE_NAME, ATTR_SERVICE_VERSION } from "@opentelemetry/semantic-conventions";
Alternatively, pin @opentelemetry/semantic-conventions to 1.43.0, which resolves
to the CJS build in ESM contexts and still provides a default export.
Verify by packing the package, installing it into a clean prefix with a fresh
npm install, and running cmd --version.
Additional context
Node.js: v26.8.1
npm: 11.19.0
Fresh install resolves @opentelemetry/semantic-conventions@1.44.0 due to the ^1.30.0 range.
1.44.0 exports require -> dist/index.cjs but default -> dist/index.mjs; the ESM entry only has named exports. Earlier versions such as 1.43.0 resolve to the CJS build in ESM contexts, so the default import works.
Replacing the installed @opentelemetry/semantic-conventions with 1.43.0 makes cmd --version work again.
The other OpenTelemetry imports (resources, sdk-trace-node, exporter-trace-otlp-http) still provide a CJS default and are not affected.****
Activity
vipulgupta2048 commentedon Oct 29, 2026
Should be fixed now in the latest CLI version 1.88.2
Let us know if you have any questions.